Configuring ubuntu

来自百问网嵌入式Linux wiki
跳转至: 导航搜索

ubuntu16.04安装

ubuntu16.04-android环境配置

linux kernel环境配置

  • 基本依赖
sudo apt-get install gcc make git vim python net-tools openssh-server \
  python-dev build-essential subversion \
 libncurses5-dev zlib1g-dev gawk gcc-multilib flex git-core gettext  \
  gfortran libssl-dev libpcre3-dev xlibmesa-glu-dev libglew1.5-dev \
  libftgl-dev libmysqlclient-dev libfftw3-dev libcfitsio-dev graphviz-dev \
  libavahi-compat-libdnssd-dev libldap2-dev  libxml2-dev p7zip-full \
  libkrb5-dev libgsl0-dev  u-boot-tools  -y

编译android 5.1

  • 安装java-jdk-1.7
sudo add-apt-repository ppa:openjdk-r/ppa
sudo apt-get update
sudo apt-get install openjdk-7-jdk
sudo update-java-alternatives -s java-1.7.0-openjdk-amd64
sudo java -version
  • 安装编译android 5.1依赖环境
sudo apt-get install -y git flex bison gperf build-essential libncurses5-dev:i386 libc6-dev-i386 \
libx11-dev:i386 libreadline6-dev:i386 libgl1-mesa-dev g++-multilib \
tofrodos python-markdown libxml2-utils xsltproc zlib1g-dev:i386 \
dpkg-dev libsdl1.2-dev libesd0-dev \
git-core gnupg flex bison gperf build-essential  \
zip curl zlib1g-dev gcc-multilib g++-multilib \
lib32ncurses5-dev x11proto-core-dev libx11-dev \
lib32z-dev ccache  squashfs-tools libncurses5-dev  pngcrush schedtool libxml2\
libgl1-mesa-dev  unzip m4 lzop libc6-dev  lib32z1-dev \
libswitch-perl libssl1.0.0 libssl-dev

ubuntu18.04安装

linux kernel环境配置

  • 基本依赖
sudo apt-get install gcc make git vim python net-tools openssh-server \
  python-dev build-essential subversion \
 libncurses5-dev zlib1g-dev gawk gcc-multilib flex git-core gettext  \
  gfortran libssl-dev libpcre3-dev xlibmesa-glu-dev libglew1.5-dev \
  libftgl-dev libmysqlclient-dev libfftw3-dev libcfitsio-dev graphviz-dev \
  libavahi-compat-libdnssd-dev libldap2-dev  libxml2-dev p7zip-full \
  libkrb5-dev libgsl0-dev  u-boot-tools  -y

ubuntu18.04-android环境配置

编译android 7.1

  • 安装java-jdk-1.8
sudo apt-get install openjdk-8-jdk openjdk-8-jre
sudo java -version
  • 安装编译android 7.1依赖环境
sudo apt-get install m4  g++-multilib gcc-multilib \
lib32ncurses5-dev  lib32readline6-dev lib32z1-dev flex curl bison

编译android 8.1

  • 安装java-jdk-1.8
sudo apt-get install openjdk-8-jdk openjdk-8-jre
sudo java -version
  • 安装编译android 7.1依赖环境
sudo apt-get install libx11-dev:i386 libreadline6-dev:i386 libgl1-mesa-dev g++-multilib \
 git flex bison gperf build-essential libncurses5-dev:i386 \
 dpkg-dev libsdl1.2-dev libesd0-dev \
 git-core gnupg flex bison gperf build-essential \
 zip curl zlib1g-dev gcc-multilib g++-multilib \
 libc6-dev-i386  lib32ncurses5-dev x11proto-core-dev libx11-dev \
 libgl1-mesa-dev libxml2-utils xsltproc unzip m4 \
 lib32z1-dev ccache make  tofrodos \
 python-markdown libxml2-utils xsltproc zlib1g-dev:i386 -y


环境配置

安装配置TFTP服务端

安装TFTP服务

book@100ask:~$ sudo apt-get install tftp-hpa tftpd-hpa

然后,创建TFTP服务器工作目录,并打开TFTP服务配置文件,如下:

book@100ask:~$ mkdir -p /home/book/tftpboot
book@100ask:~$ chmod 777 /home/book/tftpboot
book@100ask:~$ sudo vim /etc/default/tftpd-hpa

在配置文件/etc/default/tftpd-hpa中,添加以下字段:

TFTP_DIRECTORY="/home/book/tftpboot"
TFTP_OPTIONS="-l -c -s"

最后,重启TFTP服务:

book@100ask:~$ sudo service tftpd-hpa restart

安装并配置NFS服务

NFS即网络文件系统,允许开发板直接通过网络挂载PC机中的文件夹。下面介绍在ubuntu上的NFS服务安装和配置。
首先,执行以下命令安装NFS服务:

book@100ask:~$ sudo apt-get install nfs-kernel-server

然后编辑/etc/exports文件,添加NFS服务导出的工作目录:

book@100ask:~$ sudo vim /etc/exports

添加NFS目录:下面以/home/book/rootfs为例,将其添加到/etc/exports文件中, 如下:

/home/book/nfs_rootfs  *(rw,nohide,insecure,no_subtree_check,async,no_root_squash)

最后,重启NFS服务:

book@100ask:~$ sudo service nfs-kernel-server restart

如果一切正常,可以在ubuntu中测试NFS服务:

book@100ask:~$ sudo  mount  -t  nfs  127.0.0.1:/home/book/nfs_rootfs    /mnt

通过samba传输文件

通过sftp协议传输文件

使用vmware共享windows磁盘